+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 20 of 21

Thread: FFXI + WIN 7 + Slow FPS     submit to reddit submit to twitter

  1. #1
    2600klub

    Loves tits more than you

    Join Date
    Apr 2009
    Posts
    3,083
    BG Level
    7
    FFXI Server
    Shiva

    FFXI + WIN 7 + Slow FPS

    So Like the title says,

    Im running FFXI and anywhere I go, it's like 5-12 fps Max, I'm laptop might explode if I go to Whitegate. I had no issues with fps when i was using Xp, Now I'm on Win7, My laptop should run it fine since I had vista on it and FFXI also ran smooth(lolvista).

    Laptop Specs:
    AMD Turion X2 (2.0ghz) (lolamd)
    3gb of Ram
    Win7 64bit

    I downloading the latest drivers and see if that helps too but Suggestions are welcome

  2. #2

    You forgot to list your video card you faggot.

  3. #3
    2600klub

    Loves tits more than you

    Join Date
    Apr 2009
    Posts
    3,083
    BG Level
    7
    FFXI Server
    Shiva

    Oh ya

    Ati Radeon X1250

    And drivers didnt help

  4. #4

    Did you uninstall them, reboot into safe mode, use a driver cleaner, then install the new drivers?

  5. #5
    2600klub

    Loves tits more than you

    Join Date
    Apr 2009
    Posts
    3,083
    BG Level
    7
    FFXI Server
    Shiva

    >_> no, but the Catalyst shit wasnt installed yet so there was no real replacement

  6. #6
    The Wang
    Join Date
    Jun 2006
    Posts
    1,345
    BG Level
    6
    FFXIV Character
    Furt Wangler
    FFXIV Server
    Coeurl
    FFXI Server
    Sylph

    catalyst control center and the actual drivers are two different things. you can use drivers without the CCC. google ati drivers and find the 9.x versions. I tried the 10.x on 7 and it fucked all kinds of stuff up. 9 works like a charm.

  7. #7
    Drunken Red Mage
    Join Date
    Sep 2006
    Posts
    2,907
    BG Level
    7
    FFXIV Character
    Auspice Lasserott
    FFXIV Server
    Hyperion
    FFXI Server
    Cerberus

    How are you people installing 9 on Windows 7? When I choose 7 as my OS it doesn't give me the option of downloading past drivers like it did with XP.

  8. #8
    2600klub

    Loves tits more than you

    Join Date
    Apr 2009
    Posts
    3,083
    BG Level
    7
    FFXI Server
    Shiva

    Quote Originally Posted by Furtwangler View Post
    catalyst control center and the actual drivers are two different things. you can use drivers without the CCC. google ati drivers and find the 9.x versions. I tried the 10.x on 7 and it fucked all kinds of stuff up. 9 works like a charm.
    gotta link? Keeps linking me to CCC shit

  9. #9
    The Wang
    Join Date
    Jun 2006
    Posts
    1,345
    BG Level
    6
    FFXIV Character
    Furt Wangler
    FFXIV Server
    Coeurl
    FFXI Server
    Sylph

    http://downloads.guru3d.com/Videocar...Win-7_c31.html
    I'm currently using
    http://downloads.guru3d.com/ATI-Cata...load-2450.html

    They still call them Catalyst drivers, but the CCC is totally unrelated, confusing I know.

  10. #10
    Drunken Red Mage
    Join Date
    Sep 2006
    Posts
    2,907
    BG Level
    7
    FFXIV Character
    Auspice Lasserott
    FFXIV Server
    Hyperion
    FFXI Server
    Cerberus

    The last Catalyst drivers I had success with on XP was 9.1 but I don't see any 64bit 7 supported 9.1 drivers, which ones are you guys having luck with?

  11. #11
    The Wang
    Join Date
    Jun 2006
    Posts
    1,345
    BG Level
    6
    FFXIV Character
    Furt Wangler
    FFXIV Server
    Coeurl
    FFXI Server
    Sylph

    the second link I posted/ it says ATI Catalyst 9.12 hotfix Win 7 | Vista (32|64-bit)

  12. #12
    Drunken Red Mage
    Join Date
    Sep 2006
    Posts
    2,907
    BG Level
    7
    FFXIV Character
    Auspice Lasserott
    FFXIV Server
    Hyperion
    FFXI Server
    Cerberus

    Cool, I'll try them but there were tons of choices newer than the 9.1 I was using on XP so I wasn't sure which one to pick.

  13. #13
    The Wang
    Join Date
    Jun 2006
    Posts
    1,345
    BG Level
    6
    FFXIV Character
    Furt Wangler
    FFXIV Server
    Coeurl
    FFXI Server
    Sylph

    me neither, just picked that one and it worked haha, if it doesnt, try others.

  14. #14
    Drunken Red Mage
    Join Date
    Sep 2006
    Posts
    2,907
    BG Level
    7
    FFXIV Character
    Auspice Lasserott
    FFXIV Server
    Hyperion
    FFXI Server
    Cerberus

    Working much better than the 10.1 drivers I was using, haven't noticed any of the goofy glitches I'd randomly get yet either so hopefully everything is all good.

  15. #15
    2600klub

    Loves tits more than you

    Join Date
    Apr 2009
    Posts
    3,083
    BG Level
    7
    FFXI Server
    Shiva

    Still nothing, i downloaded link installed rebooted, still running at like 9fps

  16. #16
    The Wang
    Join Date
    Jun 2006
    Posts
    1,345
    BG Level
    6
    FFXIV Character
    Furt Wangler
    FFXIV Server
    Coeurl
    FFXI Server
    Sylph

    make sure you're downloading http://downloads.guru3d.com/Guru3D--...load-1655.html and cleaning out the rest of the old drivers (need to do it in safe mode)
    Random question but are you using windower? fullscreen? try switching around if you are using windower just for the hell of it to see if it changes anything.

  17. #17
    2600klub

    Loves tits more than you

    Join Date
    Apr 2009
    Posts
    3,083
    BG Level
    7
    FFXI Server
    Shiva

    Quote Originally Posted by Furtwangler View Post
    make sure you're downloading http://downloads.guru3d.com/Guru3D--...load-1655.html and cleaning out the rest of the old drivers (need to do it in safe mode)
    Random question but are you using windower? fullscreen? try switching around if you are using windower just for the hell of it to see if it changes anything.
    Ill try the driver things and Im using windower but not fullscreen,I even took off WIn7 Aero theme and nothing

  18. #18
    The Wang
    Join Date
    Jun 2006
    Posts
    1,345
    BG Level
    6
    FFXIV Character
    Furt Wangler
    FFXIV Server
    Coeurl
    FFXI Server
    Sylph

    That much of a drop def isn't because of the load on the card, so aero disabling is probably redundant (although weird shit works sometimes) try using fullscreen no windower and see if there's an increase, every now and then windower would cause weird shit for me when I played.

  19. #19
    2600klub

    Loves tits more than you

    Join Date
    Apr 2009
    Posts
    3,083
    BG Level
    7
    FFXI Server
    Shiva

    Still nothing!!!!!!!!!!!

  20. #20

    Time to get a new laptop with an nvidia card.

Similar Threads

  1. FFXI ATI 5870 fps problem
    By Osede in forum Tech
    Replies: 11
    Last Post: 2010-07-12, 23:24
  2. FFXI and Low FPS
    By Marcicus in forum Tech
    Replies: 3
    Last Post: 2009-03-11, 12:45
  3. Vista/Windower/FFXI/Nvidia Low FPS problem
    By Astarael in forum Tech
    Replies: 2
    Last Post: 2008-09-25, 05:27
  4. Replies: 8
    Last Post: 2008-05-28, 01:42
  5. FPS/System Lag spikes with FFXI
    By Wintermute in forum Tech
    Replies: 9
    Last Post: 2008-03-08, 20:32
  6. Random fps drop in ffxi
    By Keria in forum Tech
    Replies: 3
    Last Post: 2007-10-11, 04:08
  7. nVidia 7950GT, Vista & FFXI fps woes
    By Robert in forum Tech
    Replies: 2
    Last Post: 2007-04-18, 12:42